Creates new areas
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElementSet NewAreas( List<AreaCreationData> dataList ) |
Visual Basic |
---|
Public Function NewAreas ( _ dataList As List(Of AreaCreationData) _ ) As ElementSet |
Visual C++ |
---|
public: ElementSet^ NewAreas( List<AreaCreationData^>^ dataList ) |
Parameters
- dataList
- Type: System.Collections.Generic..::..List<(Of <(<'AreaCreationData>)>)>
A list of AreaCreationData which wraps the creation arguments of the areas to be created.
Return Value
If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | If AreaCreationData's areaPoint is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation. |