Moves the ImageInstance to the specified location
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public void SetLocation( XYZ newLocation, BoxPlacement placementPoint ) |
Visual Basic |
---|
Public Sub SetLocation ( _ newLocation As XYZ, _ placementPoint As BoxPlacement _ ) |
Visual C++ |
---|
public: void SetLocation( XYZ^ newLocation, BoxPlacement placementPoint ) |
Parameters
- newLocation
- Type: Autodesk.Revit.DB..::..XYZ
The new location of the specified point
- placementPoint
- Type: Autodesk.Revit.DB..::..BoxPlacement
The placementPoint specifies which point of the ImageInstance should be placed at the given location.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given newLocation is more than 10 miles from the origin of the model |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |