Checks whether this FormatOptions is valid for a given spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsValidForSpec( ForgeTypeId specTypeId ) |
Visual Basic |
---|
Public Function IsValidForSpec ( _ specTypeId As ForgeTypeId _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidForSpec( ForgeTypeId^ specTypeId ) |
Parameters
- specTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec.
Return Value
True if the FormatOptions is valid, false otherwise.
Remarks
The FormatOptions is valid if UseDefault is true or if the unit in
the FormatOptions is valid for the spec. See
UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and
UnitUtils.GetValidUnits(ForgeTypeId).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a spec identifier. See UnitUtils.IsSpec(ForgeTypeId) and UnitUtils.GetSpecTypeId(UnitType). |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |