Checks whether a unit is valid for a given spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool IsValidUnit( ForgeTypeId specTypeId, ForgeTypeId unitTypeId ) |
Visual Basic |
---|
Public Shared Function IsValidUnit ( _ specTypeId As ForgeTypeId, _ unitTypeId As ForgeTypeId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidUnit( ForgeTypeId^ specTypeId, ForgeTypeId^ unitTypeId ) |
Parameters
- specTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec.
- unitTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to check.
Return Value
True if the unit is valid, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a spec identifier. See UnitUtils.IsSpec(ForgeTypeId) and UnitUtils.GetSpecTypeId(UnitType). |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |