Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public ElementPhaseStatusFilter( ElementId phaseId, ElementOnPhaseStatus phaseStatus ) |
Visual Basic |
---|
Public Sub New ( _ phaseId As ElementId, _ phaseStatus As ElementOnPhaseStatus _ ) |
Visual C++ |
---|
public: ElementPhaseStatusFilter( ElementId^ phaseId, ElementOnPhaseStatus phaseStatus ) |
Parameters
- phaseId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
- phaseStatus
- Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
Target status.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |