The name of the non-continuous rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2019

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
	Get
	Set
Visual C++
public:
property String^ Name {
	String^ get ();
	void set (String^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException When setting this property: name is an empty string or contains only whitespace. -or- When setting this property: name cannot include prohibited characters. -or- When setting this property: The name name is not valid for the non-continuous rail.
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL

See Also