Gets the locations for the calculation points for this instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public IList<XYZ> GetSpatialElementFromToCalculationPoints() |
Visual Basic |
---|
Public Function GetSpatialElementFromToCalculationPoints As IList(Of XYZ) |
Visual C++ |
---|
public: IList<XYZ^>^ GetSpatialElementFromToCalculationPoints() |
Return Value
A list of 3d points.
Remarks
For a family instance which connects two rooms or spaces, such as a door or window, the points determine which room or space is considered the "from" and which is considered the "to".
Remarks
See HasSpatialElementFromToCalculationPoints for reference.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this instance does not have from/to calculation points.. |