Implement this method to return the name of the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
string GetName() |
Visual Basic |
---|
Function GetName As String |
Visual C++ |
---|
String^ GetName() |
Return Value
Name of the service.
Remarks
Although an external service is uniquely identified by its Id, the Name can identify it to the end user in UI when UI is appropriate for the service.
Beside the requirement for the name to be a non-empty string, there are no other general restrictions imposed by the External Services Framework.