Initiates a drag and drop operation with a custom drop implementation.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static void DoDragDrop( Object dropData, IDropHandler handler ) |
Visual Basic |
---|
Public Shared Sub DoDragDrop ( _ dropData As Object, _ handler As IDropHandler _ ) |
Visual C++ |
---|
public: static void DoDragDrop( Object^ dropData, IDropHandler^ handler ) |
Parameters
- dropData
- Type: System..::..Object
Any arbitrary data to be passed to the drop handler when the drop occurs.
- handler
- Type: Autodesk.Revit.UI..::..IDropHandler
The handler to be executed when the drop occurs.
Remarks
When the user inputs IControllableDropHandler,
it allows the handler to verify whether the drop event can be executed on the given view;
When the user inputs IDropHandler
the handler will be executed without any condition.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when dropData or handler is nullNothingnullptra null reference (Nothing in Visual Basic). |