Indicates whether this parameter is driven by a dimension or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public bool IsDrivenByDimension { get; } |
Visual Basic |
---|
Public ReadOnly Property IsDrivenByDimension As Boolean Get |
Visual C++ |
---|
public: property bool IsDrivenByDimension { bool get (); } |
Remarks
Only reporting parameters can be driven by dimensions. Thus, to drive a parameter by a dimension, the parameter must first be set as reporting before it is used to label the driving dimension.
Note that the value of this property is always the opposite of the IsDrivenByFormula property. It is so because a parameter of which value is evaluated by a formula cannot be driven by a dimension, and vice versa.