Gets the category type of this category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public CategoryType CategoryType { get; } |
Visual Basic |
---|
Public ReadOnly Property CategoryType As CategoryType Get |
Visual C++ |
---|
public: property CategoryType CategoryType { CategoryType get (); } |
Remarks
The category type determines if the category is shown in the Visibility/Graphics settings
grouped with the model,annotation, or analytical model categories.
Note that import categories are also "model" but will be shown separately in the dialog.
Some categories not shown in the dialog and will return Internal for the category type.