Creates a ChangeType that is a union of the two input ChangeTypes
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static ChangeType ConcatenateChangeTypes( ChangeType changeType1, ChangeType changeType2 ) |
Visual Basic |
---|
Public Shared Function ConcatenateChangeTypes ( _ changeType1 As ChangeType, _ changeType2 As ChangeType _ ) As ChangeType |
Visual C++ |
---|
public: static ChangeType^ ConcatenateChangeTypes( ChangeType^ changeType1, ChangeType^ changeType2 ) |
Parameters
- changeType1
- Type: Autodesk.Revit.DB..::..ChangeType
First input ChangeType to be concatenated
- changeType2
- Type: Autodesk.Revit.DB..::..ChangeType
Second input ChangeType to be concatenated
Return Value
A new ChangeType that is a concatenation/union of the input change types
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |