Remove existing shared parameter as a dependency for the calculation of the rebar curves.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public void RemoveUpdatingSharedParameter( ElementId parameterId ) |
Visual Basic |
---|
Public Sub RemoveUpdatingSharedParameter ( _ parameterId As ElementId _ ) |
Visual C++ |
---|
public: void RemoveUpdatingSharedParameter( ElementId^ parameterId ) |
Parameters
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the shared parameter to be removed.
Remarks
The input parameter needs to be bound to the Rebar element
The rebar element needs to have a valid external server
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID. -or- parameterId is a parameter that is not bound to the Rebar element category. |