Constructs a new RebarBendData using the bar type, hook types, style and orientation values.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public RebarBendData( RebarBarType barType, RebarHookType hookType0, RebarHookType hookType1, RebarStyle style, RebarHookOrientation hookOrient0, RebarHookOrientation hookOrient1 ) |
Visual Basic |
---|
Public Sub New ( _ barType As RebarBarType, _ hookType0 As RebarHookType, _ hookType1 As RebarHookType, _ style As RebarStyle, _ hookOrient0 As RebarHookOrientation, _ hookOrient1 As RebarHookOrientation _ ) |
Visual C++ |
---|
public: RebarBendData( RebarBarType^ barType, RebarHookType^ hookType0, RebarHookType^ hookType1, RebarStyle style, RebarHookOrientation hookOrient0, RebarHookOrientation hookOrient1 ) |
Parameters
- barType
- Type: Autodesk.Revit.DB.Structure..::..RebarBarType
- hookType0
- Type: Autodesk.Revit.DB.Structure..::..RebarHookType
- hookType1
- Type: Autodesk.Revit.DB.Structure..::..RebarHookType
- style
- Type: Autodesk.Revit.DB.Structure..::..RebarStyle
- hookOrient0
- Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
- hookOrient1
- Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |