The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class RebarBendData : IDisposable |
Visual Basic |
---|
Public Class RebarBendData _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarBendData : IDisposable |
Remarks
The purpose of collecting the values in this class is to allow you to
create and analyze an accurate representation of a RebarShape, without creating a Rebar
instance, and without referring to RebarBarType, RebarHookType, and RebarStyle.
If you do have a Rebar instance, its GetBendData() method will produce a RebarBendData
object.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarBendData
Autodesk.Revit.DB.Structure..::..RebarBendData