Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical
Support Information from Elements.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public IList<AnalyticalModelSupport> GetAnalyticalModelSupports() |
Visual Basic |
---|
Public Function GetAnalyticalModelSupports As IList(Of AnalyticalModelSupport) |
Visual C++ |
---|
public: IList<AnalyticalModelSupport^>^ GetAnalyticalModelSupports() |
Return Value
Array of AnalyticalModelSupport objects, each one representing a support.
Remarks
If an Element is not supported by anything, the array returned should be empty.