Look up a column attachment by specifying the target id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static ColumnAttachment GetColumnAttachment( FamilyInstance column, ElementId targetId ) |
Visual Basic |
---|
Public Shared Function GetColumnAttachment ( _ column As FamilyInstance, _ targetId As ElementId _ ) As ColumnAttachment |
Visual C++ |
---|
public: static ColumnAttachment^ GetColumnAttachment( FamilyInstance^ column, ElementId^ targetId ) |
Parameters
- column
- Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
- targetId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a target element.
Return Value
The column attachment attaching the column to the target, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no such attachment.
Remarks
May return either a top or base attachment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |