Returns the pointer to the section data array element at the specified section type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public TableSectionData GetSectionData( SectionType sectionType ) |
Visual Basic |
---|
Public Function GetSectionData ( _ sectionType As SectionType _ ) As TableSectionData |
Visual C++ |
---|
public: TableSectionData^ GetSectionData( SectionType sectionType ) |
Parameters
- sectionType
- Type: Autodesk.Revit.DB..::..SectionType
The section type of section data array. If the integral value of the section type is out of the boundary of section data array, null is returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |