Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public ElementOwnerViewFilter(
	ElementId viewId
)
Visual Basic
Public Sub New ( _
	viewId As ElementId _
)
Visual C++
public:
ElementOwnerViewFilter(
	ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also