Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public bool AlmostEqual( Transform2D right ) |
Visual Basic |
---|
Public Function AlmostEqual ( _ right As Transform2D _ ) As Boolean |
Visual C++ |
---|
public: bool AlmostEqual( Transform2D^ right ) |
Parameters
- right
- Type: Autodesk.Revit.DB..::..Transform2D
The transformation to compare with this transformation.
Return Value
True if the two transformations are equal, false otherwise.
Remarks
The tolerance is applied memberwise for comparison.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |