Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
public static bool IsWallBaseRectangular(
Wall wall,
Curve curve
) |
Visual Basic |
---|
Public Shared Function IsWallBaseRectangular ( _
wall As Wall, _
curve As Curve _
) As Boolean |
Visual C++ |
---|
public:
static bool IsWallBaseRectangular(
Wall^ wall,
Curve^ curve
) |
Return Value
True if the wall's base can be represented by a direct thickening of the wall's base curve.
False is the wall's base shape is affected by other geometry, and thus cannot be represented
by a direct thickening of the wall's base cure.
Exceptions
See Also