Create a constraint to drive chord length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public RebarShapeConstraintChordLength(
	ElementId paramId
)
Visual Basic
Public Sub New ( _
	paramId As ElementId _
)
Visual C++
public:
RebarShapeConstraintChordLength(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also