Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public BoundingBoxIntersectsFilter(
	Outline outline,
	double tolerance
)
Visual Basic
Public Sub New ( _
	outline As Outline, _
	tolerance As Double _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
	Outline^ outline, 
	double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also