Creates an array of new model line elements.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ModelCurveArray NewModelCurveArray( CurveArray geometryCurveArray, SketchPlane sketchPlane ) |
Visual Basic |
---|
Public Function NewModelCurveArray ( _ geometryCurveArray As CurveArray, _ sketchPlane As SketchPlane _ ) As ModelCurveArray |
Visual C++ |
---|
public: ModelCurveArray^ NewModelCurveArray( CurveArray^ geometryCurveArray, SketchPlane^ sketchPlane ) |
Parameters
- geometryCurveArray
- Type: Autodesk.Revit.DB..::..CurveArray
An array containing the internal geometry curves for model lines.
- sketchPlane
- Type: Autodesk.Revit.DB..::..SketchPlane
Return Value
If successful an array of new model line elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Remarks
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in the plane |