Create a PointRelativeToPoint object, which is used to define
the placement of a ReferencePoint relative to a host point.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public PointRelativeToPoint NewPointRelativeToPoint( Reference hostPointReference ) |
Visual Basic |
---|
Public Function NewPointRelativeToPoint ( _ hostPointReference As Reference _ ) As PointRelativeToPoint |
Visual C++ |
---|
public: PointRelativeToPoint^ NewPointRelativeToPoint( Reference^ hostPointReference ) |
Parameters
- hostPointReference
- Type: Autodesk.Revit.DB..::..Reference
The reference of the host point.
Return Value
If creation is successful then a new PointRelativeToPoint object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument hostPointReference is nullNothingnullptra null reference (Nothing in Visual Basic). |