Gets the extents of the grid in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public Outline GetExtents()
Visual Basic
Public Function GetExtents As Outline
Visual C++
public:
Outline^ GetExtents()

Return Value

The extents are the 3D bounding box surrounding the grid. The Z coordinates of the box are used by Revit to determine if the grid should be displayed in a corresponding view plan (if the grid is linear). The extents are not used for arc grids.

See Also