Returns the vertex with a given index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public XYZ GetVertex( int vertexIndex ) |
Visual Basic |
---|
Public Function GetVertex ( _ vertexIndex As Integer _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ GetVertex( int vertexIndex ) |
Parameters
- vertexIndex
- Type: System..::..Int32
The index of the vertex (between 0 and getVertexCount()-1, inclusive).
Return Value
A copy of the requested vertex.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is out of range. |