Adds a new ToggleButton to the RadioButtonGroup.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public ToggleButton AddItem( ToggleButtonData buttonData ) |
Visual Basic |
---|
Public Function AddItem ( _ buttonData As ToggleButtonData _ ) As ToggleButton |
Visual C++ |
---|
public: ToggleButton^ AddItem( ToggleButtonData^ buttonData ) |
Parameters
- buttonData
- Type: Autodesk.Revit.UI..::..ToggleButtonData
An object containing the data needed to construct the ToggleButton.
Return Value
The newly added ToggleButton.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with buttonData.Name already exists in the group. |