Checks whether a ForgeTypeId identifies a spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool IsSpec( ForgeTypeId specTypeId ) |
Visual Basic |
---|
Public Shared Function IsSpec ( _ specTypeId As ForgeTypeId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsSpec( ForgeTypeId^ specTypeId ) |
Parameters
- specTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier to check.
Return Value
True if the ForgeTypeId identifies a spec, false otherwise.
Remarks
A ForgeTypeId identifies a spec if it corresponds to a valid
UnitType value according to
UnitUtils.IsValidUnitType(UnitType) and
UnitUtils.GetSpecTypeId(UnitType).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |