Gets the ForgeTypeId identifying the spec corresponding to the given unit type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. It will not be replaced, but until its removal it may be used to help migrate code that uses the `UnitType` enumeration to the `ForgeTypeId` class.")]
public static ForgeTypeId GetSpecTypeId(
UnitType unitTypeEnum
) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. It will not be replaced, but until its removal it may be used to help migrate code that uses the `UnitType` enumeration to the `ForgeTypeId` class.")> _
Public Shared Function GetSpecTypeId ( _
unitTypeEnum As UnitType _
) As ForgeTypeId |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. It will not be replaced, but until its removal it may be used to help migrate code that uses the `UnitType` enumeration to the `ForgeTypeId` class.")]
public:
static ForgeTypeId^ GetSpecTypeId(
UnitType unitTypeEnum
) |
Return Value
Identifier of the spec corresponding to the given unit type.
Exceptions
See Also