Prompts the end-user to control whether a type parameter contained in the specified table cell should be allowed edited.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static bool TestCellAndPromptToEditTypeParameter( TableView tableView, SectionType sectionType, int row, int column ) |
Visual Basic |
---|
Public Shared Function TestCellAndPromptToEditTypeParameter ( _ tableView As TableView, _ sectionType As SectionType, _ row As Integer, _ column As Integer _ ) As Boolean |
Visual C++ |
---|
public: static bool TestCellAndPromptToEditTypeParameter( TableView^ tableView, SectionType sectionType, int row, int column ) |
Parameters
- tableView
- Type: Autodesk.Revit.DB..::..TableView
The table view.
- sectionType
- Type: Autodesk.Revit.DB..::..SectionType
The section the row lies in.
- row
- Type: System..::..Int32
The row index in the section.
- column
- Type: System..::..Int32
The column index in the section.
Return Value
Returns true if editing the cell is allowed; otherwise false.
Remarks
If the specified cell contains an instance parameter, the method automatically returns true without prompting the user.
For type parameters, a task dialog will be shown and the user's choice will be returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration |