The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public LeaderEndCondition LeaderEndCondition { get; set; } |
Visual Basic |
---|
Public Property LeaderEndCondition As LeaderEndCondition Get Set |
Visual C++ |
---|
public: property LeaderEndCondition LeaderEndCondition { LeaderEndCondition get (); void set (LeaderEndCondition value); } |
Remarks
LeaderEndCondition enumerates the supported leader end conditions.
Material tags and material keynotes can only use the free end condition.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: LeaderEndCondition cannot be assigned. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |