Gets override settings associated with a DirectContext3D handle instance or type.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public DirectContext3DHandleSettings GetDirectContext3DHandleSettings( Document aDoc, ElementId elementId ) |
Visual Basic |
---|
Public Function GetDirectContext3DHandleSettings ( _ aDoc As Document, _ elementId As ElementId _ ) As DirectContext3DHandleSettings |
Visual C++ |
---|
public: DirectContext3DHandleSettings^ GetDirectContext3DHandleSettings( Document^ aDoc, ElementId^ elementId ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
Document where elementId resides.
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the overridden element.
Return Value
The override settings assigned to the handle element, if present, or a default override settings if nothing was found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId elementId is not a valid DirectContext3D handle instance or type. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |