Creates a new SpaceTag.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public SpaceTag NewSpaceTag( Space space, UV point, View view ) |
Visual Basic |
---|
Public Function NewSpaceTag ( _ space As Space, _ point As UV, _ view As View _ ) As SpaceTag |
Visual C++ |
---|
public: SpaceTag^ NewSpaceTag( Space^ space, UV^ point, View^ view ) |
Parameters
- space
- Type: Autodesk.Revit.DB.Mechanical..::..Space
The Space which the tag refers.
- point
- Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on the level of the space.
- view
- Type: Autodesk.Revit.DB..::..View
The view where the tag will lie.
Return Value
If successful a SpaceTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the space does not exist in the given document. |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the view does not exist in the given document. |