Gets the curve loop corresponding to the hole in the wall made by the instance.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static CurveLoop GetInstanceCutoutFromWall( Document pADoc, Wall pVWall, FamilyInstance pFamInst, out XYZ pCutDir ) |
Visual Basic |
---|
Public Shared Function GetInstanceCutoutFromWall ( _ pADoc As Document, _ pVWall As Wall, _ pFamInst As FamilyInstance, _ <OutAttribute> ByRef pCutDir As XYZ _ ) As CurveLoop |
Visual C++ |
---|
public: static CurveLoop^ GetInstanceCutoutFromWall( Document^ pADoc, Wall^ pVWall, FamilyInstance^ pFamInst, [OutAttribute] XYZ^% pCutDir ) |
Parameters
- pADoc
- Type: Autodesk.Revit.DB..::..Document
The document.
- pVWall
- Type: Autodesk.Revit.DB..::..Wall
The host wall.
- pFamInst
- Type: Autodesk.Revit.DB..::..FamilyInstance
The hosted instance.
- pCutDir
- Type: Autodesk.Revit.DB..::..XYZ%
The direction of the hole relative to the location of the curve loop.
Return Value
The opening in the wall.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |