Sets the analytical model projection to a preset value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public void SetProjection(
	AnalyticalElementSelector selector,
	ElementId planeIdY,
	ElementId planeIdZ
)
Visual Basic
Public Sub SetProjection ( _
	selector As AnalyticalElementSelector, _
	planeIdY As ElementId, _
	planeIdZ As ElementId _
)
Visual C++
public:
void SetProjection(
	AnalyticalElementSelector selector, 
	ElementId^ planeIdY, 
	ElementId^ planeIdZ
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
planeIdY
Type: Autodesk.Revit.DB..::..ElementId
Plane on to which analytical model may be projected in Y direction. Plane identifies a Level, a Grid, or a Ref Plane.
planeIdZ
Type: Autodesk.Revit.DB..::..ElementId
Plane on to which analytical model may be projected in Z direction. Plane identifies a Level, a Grid, or a Ref Plane.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also