Get all the custom Panels on a designated Revit tab.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual List<RibbonPanel> GetRibbonPanels( string tabName ) |
Visual Basic |
---|
Public Overridable Function GetRibbonPanels ( _ tabName As String _ ) As List(Of RibbonPanel) |
Visual C++ |
---|
public: virtual List<RibbonPanel^>^ GetRibbonPanels( String^ tabName ) |
Parameters
- tabName
- Type: System..::..String
The name of the tab on which the panels are located.
Remarks
Built-in panels will not be included. tabName must be the name of one of the tabs added
by CreateRibbonTab(String).
This method is not supported in Macros.