Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016
Syntax
Parameters
- group
- Type: System..::..String
The fabrication connector group.
- name
- Type: System..::..String
The fabrication connector name.
- domain
- Type: Autodesk.Revit.DB..::..ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
- shape
- Type: Autodesk.Revit.DB..::..ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.
Return Value
Return the fabrication connector identifier. Returns -1 if not found.
Exceptions
See Also