Determines whether the transaction has ended already.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool HasEnded() |
Visual Basic |
---|
Public Function HasEnded As Boolean |
Visual C++ |
---|
public: bool HasEnded() |
Return Value
True if the transaction has already been committed or rolled back, False otherwise.
Remarks
A transaction is ended by completing either the 'Commit' or 'RollBack' method.
Another way of testing whether a transaction has ended is by testing
the current status (see GetStatus()()()()). It must be either
'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'