Returns the current status of the transaction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public TransactionStatus GetStatus() |
Visual Basic |
---|
Public Function GetStatus As TransactionStatus |
Visual C++ |
---|
public: TransactionStatus GetStatus() |
Return Value
The current status of the transaction.
Remarks
If the status was set to TransactionStatus.Pending as the result of calling
Commit or RollBack, the status will be changed later to either 'Committed'
or 'RolledBack' after failure handling is finished. That status change will
be made asynchronously.