Gets and sets the type of the segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public LinePatternSegmentType Type { get; set; } |
Visual Basic |
---|
Public Property Type As LinePatternSegmentType Get Set |
Visual C++ |
---|
public: property LinePatternSegmentType Type { LinePatternSegmentType get (); void set (LinePatternSegmentType value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |