ShapeImporterInputFormat Property |
The format of the incoming data.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ShapeImporterSourceFormat InputFormat { get; set; }
Public Property InputFormat As ShapeImporterSourceFormat
Get
Set
public:
property ShapeImporterSourceFormat InputFormat {
ShapeImporterSourceFormat get ();
void set (ShapeImporterSourceFormat value);
}
member InputFormat : ShapeImporterSourceFormat with get, set
Property Value
ShapeImporterSourceFormat
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
If this option is set to Auto (the default), the file name extension will be used to determine the input format. That covers most file-based data import workflows.
Specify the input format explicitly to perform an additional sanity check or if you are using a non-standard file extension.
See Also