ProjectLocationSetProjectPosition Method |
Sets the coordinates of a point in the ProjectLocation's coordinate system.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetProjectPosition(
XYZ point,
ProjectPosition position
)
Public Sub SetProjectPosition (
point As XYZ,
position As ProjectPosition
)
public:
void SetProjectPosition(
XYZ^ point,
ProjectPosition^ position
)
member SetProjectPosition :
point : XYZ *
position : ProjectPosition -> unit
Parameters
- point XYZ
-
- position ProjectPosition
-
Exceptions
Remarks
When setting this value, the transformations applied to the location are modified such that the passed point
becomes the specified North/South, East/West and Elevation, and the coordinate transform will have the designated
angular rotation. This is similar to the Revit command "Specify Coordinates at Point".
See Also