ServiceType Enumeration

This enumeration is used for specifying the most predominant service for the building or space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ServiceType
Members
Member nameValueDescription
kCentralHeatingRadiators0Service Type is CentralHeatingRadiators.
kCentralHeatingConvectors1Service Type is CentralHeatingConvectors.
kCentralHeatingRadiantFloor2Service Type is CentralHeatingRadiantFloor.
kCentralHeatingHotAir3Service Type is CentralHeatingHotAir.
kOtherRoomHeater4Service Type is OtherRoomHeater.
kRadiantHeaterFlue5Service Type is RadiantHeaterFlue.
kRadiantHeaterNoFlue6Service Type is RadiantHeaterNoFlue.
kRadiantHeaterMultiburner7Service Type is RadiantHeaterMultiburner.
kForcedConvectionHeaterFlue8Service Type is ForcedConvectionHeaterFlue.
kForcedConvectionHeaterNoFlue9Service Type is ForcedConvectionHeaterNoFlue.
kNoServiceType-1Service Type is NoServiceType.
kVAVSingleDuct10Service Type is VAVSingleDuct.
kVAVDualDuct11Service Type is VAVDualDuct.
kVAVIndoorPackagedCabinet12Service Type is VAVIndoorPackagedCabinet.
kVAVTerminalReheat13Service Type is VAVTerminalReheat.
kFanCoilSystem14Service Type is FanCoilSystem.
kInductionSystem15Service Type is InductionSystem.
kConstantVolumeFixedOA16Service Type is ConstantVolumeFixedOA.
kConstantVolumeVariableOA17Service Type is ConstantVolumeVariableOA.
kConstantVolumeTerminalReheat18Service Type is ConstantVolumeTerminalReheat.
kMultizoneHotDeckColdDeck19Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeDualDuct20Service Type is ConstantVolumeDualDuct.
kRadiantCooledCeilings21Service Type is RadiantCooledCeilings.
kActiveChilledBeams22Service Type is ActiveChilledBeams.
kWaterLoopHeatPump23Service Type is WaterLoopHeatPump.
kVariableRefrigerantFlow24Service Type is VariableRefrigerantFlow.
kSplitSystemsWithNaturalVentilation25Service Type is SplitSystemsWithNaturalVentilation.
kSplitSystemsWithMechanicalVentilation26Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithMechanicalVentilationWithCooling27Service Type is SplitSystemsWithMechanicalVentilationWithCooling.
Remarks
This enumerated list corresponds to the serviceType attribute in the gbXML (Green Building XML) schema and is primarily used for energy analysis.
See Also