AppearanceAssetElementGetRenderingAsset Method |
Gets the rendering asset for the appearance asset element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Asset GetRenderingAsset()
Public Function GetRenderingAsset As Asset
public:
Asset^ GetRenderingAsset()
member GetRenderingAsset : unit -> Asset
Return Value
Asset
The rendering asset held by this appearance asset element.
Remarks
The retrieved Asset may be empty if it is loaded from material library without any modification.
In this case, you can use Application.GetAssets(AssetType.Appearance) to load all preset appearance assets, and retrieve the asset by its name.
See Also