ParameterCanBeAssociatedWithGlobalParameters Method |
Tests whether this parameter can be associated with any global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanBeAssociatedWithGlobalParameters()
Public Function CanBeAssociatedWithGlobalParameters As Boolean
public:
bool CanBeAssociatedWithGlobalParameters()
member CanBeAssociatedWithGlobalParameters : unit -> bool
Return Value
Boolean
True if the given parameter can be associated (is parametrizable); False otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
This parameter does not exist in the document anymore.
|
Remarks
Only properties defined as parametrizable can be associated with global parameters.
That excludes any read-only and formula-driven parameters, as well as those that
have other explicit or implicit restrictions imposed by Revit.
See Also