LightingSource Enumeration |
Indicates the lighting scheme type in rendering settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum LightingSource
Public Enumeration LightingSource
public enum class LightingSource
MembersMember name | Value | Description |
---|
ExteriorSun | 21 |
Exterior source of light, sun only.
|
ExteriorSunAndArtificial | 22 |
Exterior source of light, sun and artificial light.
|
ExteriorArtificial | 23 |
Exterior source of light, artificial light only.
|
InteriorSun | 24 |
Interior source of light, sun only.
|
InteriorSunAndArtificial | 25 |
Interior source of light, sun and artificial light.
|
InteriorArtificial | 26 |
Interior source of light, artificial light only.
|
See Also