ExportLayerTableAdd Method |
Inserts a (key,info) pair into Export layer table.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Add(
ExportLayerKey exportLayerKey,
ExportLayerInfo exportLayerInfo
)
Public Sub Add (
exportLayerKey As ExportLayerKey,
exportLayerInfo As ExportLayerInfo
)
public:
void Add(
ExportLayerKey^ exportLayerKey,
ExportLayerInfo^ exportLayerInfo
)
member Add :
exportLayerKey : ExportLayerKey *
exportLayerInfo : ExportLayerInfo -> unit
Parameters
- exportLayerKey ExportLayerKey
-
The export layer key to be added.
- exportLayerInfo ExportLayerInfo
-
The export layer info to be added.
ExceptionsException | Condition |
---|
ArgumentException |
The key already exists in the table.
-or-
The layer info does not contain the Category as a modifier type.
|
ArgumentNullException |
A non-optional argument was null
|
See Also