RebarShapeDefinitionBySegmentsMajorSegmentIndex Property |
Index of a segment that can be considered the most important. Revit
attempts to preserve the orientation of this segment when a Rebar instance
changes its RebarShape to one with a different number of segments.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int MajorSegmentIndex { get; set; }
Public Property MajorSegmentIndex As Integer
Get
Set
public:
property int MajorSegmentIndex {
int get ();
void set (int value);
}
member MajorSegmentIndex : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: majorSegmentIndex is not between 0 and NumberOfSegments.
|
See Also