CompoundStructureGetWidth Method |
The width implied by this compound structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function GetWidth As Double
public:
double GetWidth()
member GetWidth : unit -> float
Return Value
Double
The width of a host object with this compound structure.
Remarks
If the structure is not vertically compound, then
this is simply the sum of all layers' widths. If the structure is vertically compound,
this is the width of the rectangular grid stored in the vertically compound structure.
The presence of a layer with variable width has no effect on the value returned by this method. The
value returned assumes that all layers have their specified width.
See Also